This project is read-only.

Proposal for a new Method name for GetTable

Jul 1, 2009 at 3:54 PM

Hi all

I am thinking about replacing the GetTable-Method with another Method, because GetTable can be misleading. The Method has to be simple and at the same time clear. After some studying I had the Idea: Why not just use Get? If for example you want all Companies you could write


This would give you more clarity than GetTable, because as a Client you don't really care if the Data comes from a Table or whatever. You just want a List of Objects of the specified Type.

What do you think about it? Maybe you have a better Idea for a name? Pleas discuss!

Kind regards